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1. INTRODUCCION 

Este documento titulado “Manual para el procesamiento de imágenes 

satelitales de Sentinel-2”, es uno de los resultados obtenidos dentro del 

proyecto SOJAINNOVA en el que participaron el Instituto de 

Agrobiotecnología (IdAB), unión de agricultores y ganaderos de Navarra 

(UAGN) y Cooperativa Figuras. Pretende ser una herramienta de apoyo 

brindada a los agricultores para la descripción, caracterización y estudio de 

parcelas agrícolas de la comunidad foral de Navarra, a través del uso de 

imágenes satelitales como técnica de teledetección.  

La constelación Sentinel-2 está conformada por dos satélites (a+b) con 13 

sensores multiespectrales (denominaremos bandas a cada uno de los 

sensores), que capturan información de la superficie de la tierra a diferentes 

longitudes de onda. La información de cada una de las bandas se puede 

encontrar en el sitio oficial de la agencia espacial europea 

(https://sentinel.esa.int/web/sentinel/user-guides). El tiempo de re-visita o 

resolución temporal es de 5 días y la resolución espacial es de 10m, la cual es 

considerada como adecuada para análisis de cultivos.  

Agradecemos a todas las instituciones, especialistas y agricultores 

involucradas en este proyecto y que contribuyeron en el resultado final.  

 

 

 

 

 

 

  

https://sentinel.esa.int/web/sentinel/user-guides
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2. DEFINICIONES 

a. Teledetección:  Es la acción de extraer información de un objeto sin 

entrar en contacto con el mismo. 

b. Resoución temporal: Frecuencia con la que un satelite captura una 

imagen de una misma área.  

c. Resolución espacial: Describe el tamaño del objeto más pequeño que 

el sensor puede distinguir en una imagen.  

d. Indices de vegetación:  

e. Dato ráster: Conjunto de datos almacenados en una matrix con filas y 

columnas. Al interior de la matrix se encuentran las celdas que 

corresponden a cada pixel, cada uno con atributos definidos.  

f. Dato vector: Representa atributos mediante objetos específicos de 

punto, línea o polígono.  

g. Longitud de onda: Se encuentra dentro de las características 

fundamentales de una onda y se refiere a la distancia entre dos crestas 

consecutivas de una onda.  
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3. DESCARGA DE IMAGENES 

La descarga de imágenes satelitales de Sentinel-2 se realizan desde la 

plataforma Copernicus Data Space Ecosystem (Fig. 1) de la Agencia 

Espacial Europea (ESA – por sus siglas en inglés), a través del sitio web 

https://dataspace.copernicus.eu/browser. Las imágenes son gratuitas, 

pero es necesario darse de alta como usuario (Fig. 2) para proceder a la 

descarga. El registro se hace en el apartado Login de la página principal 

y se rellena el formulario de datos.  

 

Figura 1. Página principal de la plataforma Copernicus para descarga de 

imágenes 

  

https://dataspace.copernicus.eu/browser
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Figura 2. Registro de usuario y formulario de datos 

Posterior al registro, se busca la zona de interés a estudiar. En este 

ejemplo, buscaremos la comunidad foral de Navarra al norte de España, 

específicamente en la localidad de Tudela y con la herramienta “Crear un 

área de interés” del panel derecho, dibujar la zona (Fig. 3). En el panel 

izquierdo, en la opción de “Buscar”, seleccionar SENTINEL-2 como 

fuente de datos, con el nivel de procesamiento L2A (con corrección 

atmosférica), el porcentaje de nubosidad (Fig. 3) y el rango temporal 

deseado (Fig. 4). En este caso, hemos asignado un porcentaje de 

nubosidad del 30% para descargar aquellas imágenes totalmente 

cubiertas por nubes que impiden el correcto análisis. Finalmente, 

seleccionar “BUSCAR” (Fig. 4). 

 

Figura 3. Dibujar el área de interés y seleccionar los parámetros 

 

Figura 4. Selección de las fechas de búsqueda 

Nombre 
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Una vez finalizada la búsqueda, aparecerán las imágenes disponibles que 

cumplen los requisitos señalados, en recuadros de color azul (Fig. 5). 

Para este ejercicio, hemos seleccionado la imagen de la derecha (que 

cubre la totalidad del área de interés) en la fecha correspondiente del 

2023-08-31. La descarga se realiza haciendo clic sobre la imagen y en la 

ventana emergente seleccionar el símbolo de descarga (Fig. 6).  

 

Figura 5. Selección de imagen que cumple los requisitos de búsqueda 

  

Figura 6. Icono de descarga de imagen 

Los archivos se descargan en un fichero comprimido, el cual se tendrá 

que descomprimir para acceder a las carpetas. Las imágenes de cada una 

de las bandas se encuentran en la carpeta: GRANULE > L2A… > 

Nombre 

Nombre 
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IMG_DATA > R10m, R20m o R60m.  Las bandas se encuentran 

separadas de acuerdo con la resolución espacial (10, 20 o 60m).  

 

 

 

 

4. PROCESAMIENTO DE IMAGENES 

El procesamiento de las imágenes descargadas se realiza en el software 

de uso libre QGIS. La descarga del software se realiza en el siguiente 

enlace https://qgis.org/es/site/forusers/download.html.  

Abrimos el software en un nuevo proyecto y agregamos el mapa mundial 

para una mejor visualización. Para esto se debe agregar el Plugin llamado 

“QuickMapServices” e instalarlo a través de la opción “Plugins” > Manage 

and Install Plugins > Escribir QuickMapServices en la barra de búsqueda 

(Fig. 7). Para insertar el mapa seguimos la guía como se indica en la figura 

8 a través de la opción Web > QuickMapServices >Google. 

 

Figura 7. Instalación del Plugin QuickMapService 

https://qgis.org/es/site/forusers/download.html
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Figura 8. Insertar mapa Google Satellite 

Posteriormente, se agregan las bandas descargadas con la función Layer 

> Add Layer >Add Raster Layer (Fig. 9) y seleccionar la carpeta donde se 

encuentra las bandas guardadas en la carpeta GRANULE. Se deben 

agregar todas las bandas en cada resolución espacial por separado. Las 

bandas cargadas se verán en el panel denominado “Layers”  (Fig. 10).  

 

Figura 9. Agregar las bandas descargadas 
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Figura 10. Bandas cargadas en el software 

Para agrupar las bandas en un solo archivo se debe ir a la función SCP > 

Band set (Fig. 10) . En la ventana emergente, se cargan las bandas en la 

lista y se agredan con el símbolo + al set de bandas, en la configuración 

se selecciona Sentinel-2, crear archivo raster y RUN (Fig. 11). Finalmente 

se selecciona la carpeta donde se va a guardar el archivo “set de bandas”.  

 

Figura 11. Configuración para crear el set de bandas 

Al finalizar se crea una nueva capa con todas las bandas y es en este 

archivo en el que trabajaremos para calcular los índices de vegetación. 

Para facilitar la visualización de las capas en el software, se pueden 

eliminar las bandas que hemos usado previamente. Y finalmente, se 

puede cambiar la apariencia de las imágenes con diferentes 
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combinaciones de las bandas; así, si queremos ver la imagen en “color 

natural” debemos indicar la combinación RGB (red-green-blue) = banda 

4 + banda 3 + banda 2. Para esto damos clic derecho sobre la capa del 

conjunto de bandas > Propiedades > Simbología y seleccionamos las 

bandas correspondientes para red-4, green-3 y blue-2 (Fig. 12).  

 

Figura 12. Combinar las bandas a color natural 

De esta manera, podremos buscar las parcelas de interés y delimitarlas. 

Para esto debemos dibujar los polígonos de los campos de cultivo a través 

de la función Layer > Create layer > New Shapefile layer (Fig. 13).  

 

Figura 13. Agregar una nueva capa vector para dibujar el área de interés 

En la ventana emergente, se debe seleccionar la carpeta donde se 

almacenará la nueva capa vector, definir la geometría como polígono y en 
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“additional dimensions” es importante indicar el sistema de 

georreferenciación, que en nuestro caso es EPSG:4326 – WGS 84 (Fig 14). 

Luego, sobre la capa del nuevo vector damos clic derecho, seleccionamos 

“Toggle editing” y con el puntero identificamos las esquinas del área de 

interés. Al finalizar la delimitación, damos clic derecho e identificamos la 

parcela (Fig. 15). 

 

Figura 14. Creación de un vector tipo polígono 

 

Figura 15. Dibujar la parcela de interés e identificarla 

Finalmente, podremos calcular los índices de vegetación para las parcelas 

deseadas.  
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5. CALCULO DE INDICES DE VEGETACION 

Para el cálculo de índices de vegetación, damos clic en Ráster > Ráster 

calculator y se mostrarán las bandas combinadas previamente (Fig. 16). 

En este ejemplo, calcularemos el índice NDVI que es ampliamente 

conocido y corresponde a la combinación de las bandas 8 y 4 del satélite 

Sentinel-2; sin embargo, el cálculo de otros índices se realiza de manera 

similar. Otros índices se pueden consultar en la siguiente página web: 

https://www.indexdatabase.de/. La formula del NDVI se describe a 

continuación y es la que se indica en la calculadora ráster.  

https://www.indexdatabase.de/
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𝑁𝐷𝑉𝐼 =  
(𝐵8 − 𝐵4)

(𝐵8 + 𝐵4)
 

 

Figura 16. Fórmula del índice NDVI en la ventana de Raster calculator 

El índice se calcula para toda el área de la imagen. La paleta de colores 

puede ser modificada para una mejor visualización e interpretación del 

índice dando clic derecho en la capa del índice > Propiedades > 

Simbología; en “Render type” seleccionar “Singleband pseudocolor” y en 

color ramp indicar Greens (Fig. 17 y 18). 

 

Figura 17. Cambio de color en la capa del índice 
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Figura 18. Resultado de la imagen después de modificar el color del 

índice NDVI 

Sin embargo, para obtener el NDVI únicamente en el área de interés 

debemos ir a Raster > Extraction > Click Raster by Mask layer. En la 

ventana emergente se selecciona el índice como capa de entrada y la 

región de interés como capa de máscara (mask layer) (Fig 19) y el 

resultado para las parcelas de interés se muestra en la figura 20. Como 

en pasos anteriores, se puede modificar la paleta de colores.  

 

Figura 19. Seleccionar los parámetros para calcular el NDVI en la región 

de interés 
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Figura 20. índice NDVI para la región de interés.  

Si se desea extraer el dato numérico para cada una de las parcelas de 

interés, vamos a la caja de herramientas (normalmente ubicada a la 

derecha) y buscamos “Zonal statistics”. Al abrir la ventana seleccionamos 

la zona de interés como capa de entrada, en la capa raster agregamos el 

índice calculado para la región de interés y en “statistics to calculate” 

seleccionamos los estadísticos que interesan (Fig. 21) 

  

Figura 21. Configuración de la función “Zonal statistics” 

Finalmente, se genera una nueva capa en la que al dar clic derecho y abrir 

la tabla de atributos, mostrará los datos del índice NDVI (Fig. 22) que 
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pueden ser copiados y pegados en una hoja Excel para su posterior 

análisis.  

 

Figura 22. Tabla de atributos con las estadísticas del índice NDVI para 

cada una de las parcelas de interés 

 

 

 

 

 

6. NOTAS FINALES 

Este manual describe el procedimiento para descargar imágenes 

satelitales de la constelación Sentinel-2, procesamiento de estas y cálculo 

de índices de vegetación, enfocado principalmente para aplicaciones 

agrícolas. El procesamiento y análisis de imágenes se realiza con el 

software QGIS y solo se utilizan aquellas herramientas/funciones 

necesarias para los ejemplos. Sin embargo, este software incluye muchas 

más funciones de procesamiento para los que quieran explorar o 

profundizar más.  
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